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Chapter 1. IBM TRIRIGA Report Manager

You use the Report Manager to filter, search, and sort reports. You can also link to
other reports. You can use the Report Builder tool to generate and modify reports.

In IBM® TRIRIGA®, for action buttons instead of links, set the
SYSTEM_ACTION_STYLE property in the TRIRIGAWEB.properties folder.

Report types
In the Report Manager, you create reports that you can use to search, filter, sort,
and link to other reports. You use reports to show data.

The following list describes the report types:

Report
A basic tabular report.

Graphic
Uses a query and information from web graphics that are based on
computer-aided design (CAD) drawings.

Chart Shows the data in a chart, such as a pie, bar, line, and stacked bar chart.

Summary
A tabular report that shows the totals without the detail records.

Hierarchy
Uses a query to show information in a hierarchical structure.

Metric Aggregates instance data or fact tables in a table or chart that has drill
paths, filters, and related reports.

Building reports
You use the Report Builder to create reports that can filter, sort, and search. If you
created a report or if a report is shared by a group that you are a member of, you
can see the report in the My Reports tab.

Creating reports
You create reports in the My Reports tab. There are multiple types of reports.

Procedure
1. In the My Reports tab, specify the name of the report. The naming convention

is to use a three-letter prefix, such as tri_myreport or cst_myreport.
2. Specify the ID. Use Custom or your company's numbering standards for

reports.
3. Specify the header.
4. Specify a tag to use an extra grouping for filtering.
5. Complete the report description.
6. Select the type of report.
7. Optional: Select the Track History check box to see the report history in the

History tab.
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8. Optional: On the Order & Group tab, organize the layout of the report.

Adding business objects to reports
The business objects that are in a report identify the data that is available for a
report. The report works only with data from the specified business objects.

Procedure
1. On the Business Object subtab, select Add Business Object.
2. Select a module.
3. Select one or more business objects.
4. Select one or more forms. Only the data that is associated with the forms that

are specified are included in the report.
5. Save the report.
6. Optional: To add a child business object, select the parent business object and

select Add Business Object.
7. Select one or more associate options.
8. Optional: To expand the data that you see in the report, clear the Show only

Associations defined in Data Modeler check box.
9. To designate the object as the primary associated business object, select the

Primary Associated Business Object check box. The primary associated
business object is at the top of a hierarchical structure. If you clear the check
box, the next associated business object in the hierarchical structure is the
primary associated business object.

10. Save the report.

Adding related reports
A related report is a self-contained report that has its own definition and format. It
shows additional information that the viewer might find relevant. A main report
can have more than one related report. A related report cannot have another
related report.

Procedure
1. On the Related Reports subtab, select Add.
2. Select the module.
3. Select the related reports and select OK.
4. Save the report.

Setting security access for reports
The Security subtab specifies the groups that can access a report. The owner of the
report has full access privileges.

Procedure
1. In the Security Access section, select Add.
2. Select the groups that can access the report and select Accept.
3. Select Save.

Defining report columns
The Columns tab defines which fields are used in the report. The fields that you
select are shown as the columns in the report.
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About this task

The information in the Columns tab is organized into sections. The Business Object
section indicates the source business objects. The Columns section identifies which
fields in the selected business object to include in the report. The Display columns
section specifies the order in which the selected fields are presented and the labels
that are used to identify them.

Procedure
1. Select the business objects.
2. In the Columns section, select the check box for each field to include in the

report.
3. In the Display Columns section, edit the text in the Report Label text box.
4. To specify a percentage for the display space for a field, specify a numerical

value in the Width text box.
5. Select Save.

Applying filters to a report
On the Filters tab, you specify the fields, operators, and values that determine the
results that are shown in a report. The selected filters run sequentially. Reports run
faster if the filter that filters out the most records is specified first, followed by the
one that filters out the next highest number of records

Procedure
1. Select a business object.
2. In the Columns section, for each field that is used as a filter, select the check

box in the User or System column.
3. In the User Filter Columns section and System Filter Columns section, select a

field and change the sequence in which the filters are applied.
4. To change the label that is shown for a filter, edit the text in the Report Label

text box. If the field is a time field, input the time in milliseconds or as a string
in hh:mm:ss format.

5. From the Filter Operator drop-down box, select the comparison filter operator.
6. For system filters with a value for run time, specify the value that must be

matched. To filter a Boolean field, use the values TRUE or FALSE.
7. Select the Join Operator to organize system filters in sets to further refine the

order that the filters are applied.
8. Select Save.

Filtering records based on associations
You use the Advanced tab to define the type of associated records that are used to
filter the results of the report.

Procedure
1. On the Association Filters section bar, select Add.
2. Select the module.
3. Select the business object.
4. Select the association type.
5. Use the Filter Type field and the Record/Query field to specify which records

to use to filter. You can specify a filtering record with special name values.
6. Save the report.
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Specifying aggregation settings for metric reports
Metric reports aggregate data into a table or chart.

Procedure
1. Open the metric report.
2. On the Columns tab, in the Aggregation Settings section, select Add.
3. Specify a label for the report
4. Select a function.
5. Specify a sequence number.
6. Select Field1 to specify the field where the aggregation occurs.
7. Select a target axis to identify where the aggregated data is shown.
8. Select a color to represent the aggregation.
9. Select Save.

Drilling through metric reports
You can create a metric graphic report to drill through to the underlying data in a
report. After you create a metric report that represents the underlying records, you
can associate the metric report with the metric graphic report. You can create a
metric report by creating a report with a type that is metric.

When you pick a data point in a report, the system filters the records based on that
data point. For example, you might have a metric graphic report that represents
the sum of the original budget by status. If you select the Active status data point
in the metric graphic chart, only underlying records with an Active status are
shown. Then, you can drill through from the metric report chart to the base record.

You create a metric graphic report the same way as you create a metric report.
After you define the metric report, you associate it with the target metric graphic
report. To associate the reports, open the target graphic report and go to the Order
& Group tab.

System reports
In the Report Manager, system reports are IBM TRIRIGA standard reports. A
system administrator can designate system reports as community reports.

You can create and view system reports in the System Reports tab. If a system
report is defined as a community report, you can also view it in the Community
tab.

You can create a system report in any of the basic reports types, such as chart or
metric, or you can create a system report that is one of the following types:

External
A report that was created with a third-party software, such as BIRT.

Reserve Legacy
A query that returns the results of available resources only.

Reserve
A query that acts like the Reserve Legacy query, but also uses a calendar to
determine the availability of resources.
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Chapter 2. Advanced reporting in IBM TRIRIGA

You use IBM TRIRIGA Advanced Reporting for report presentations. IBM TRIRIGA
Advanced Reporting uses the Eclipse BIRT application and an IBM TRIRIGA
plug-in for the BIRT application. Form reports show the contents of a single record.
Query reports show multi-record reports.

The BIRT application layout is grid-based, and every element must exist in an
element of the BIRT layout grid. Grid layouts align report elements onto lines,
align elements vertically into columns, and size the columns to fit the contents.
You can use grids to create a report by dragging elements into the report design.

Before you can develop BIRT reports for an IBM TRIRIGA application, you must
install the BIRT Report Designer and configure it to work with IBM TRIRIGA.

Installing the BIRT application
You install the BIRT Report Designer once. Before you begin the installation,
ensure that a supported version of the Java™ JRE is installed locally.

About this task

For the supported versions, see the Client Compatibility section of the IBM
Support Matrix.

Procedure
1. Go to BIRT 4.3.1 in the IBM Integrated Service Management (ISM) library

website.
2. Download the BIRT Report Designer - All-in-One version to a local directory.

The directory name cannot include any spaces.
3. In the folder where you downloaded BIRT, extract the birt-report-designer-

all-in-one-4_3_1.zip file, open the Eclipse folder, and select the eclipse.exe
file.

4. Select the workplace location where Eclipse stores your project files and select
OK.

Configuring BIRT Process Servers
You can configure a second IBM TRIRIGA server to offload and process BIRT
reports in a separate BIRT process. If you do not configure a separate process
server, the BIRT report processing is done on the application server.

Procedure
1. Locate the TRIRIGAWEB.properties file.
2. Set the BIRT_PROCESS_SERVER_LISTENING_PORT property to the TCP port that

communicates the two IBM TRIRIGA servers. The server detects BIRT requests
on this port.

3. Set the BIRT_PROCESS_SERVER_HOST_NAME property to the host name or IP
address of the BIRT process server.

4. Set the BIRT_PROCESS_SERVER_PORT property to the listening port that you
configured on the BIRT process server.
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5. Save the TRIRIGAWEB.properties file.
6. Restart the BIRT process server.

Installing the IBM TRIRIGA plug-in for BIRT
For IBM TRIRIGA Advanced Reporting, you must have theIBM TRIRIGA plug-in
for BIRT installed.

Procedure
1. Open the BIRT application, and select Help > Install New Software.
2. In the Work With field, specify the following URL for the IBM TRIRIGA

plug-in software site: http://[server:port]/[context path]/eclipse. Use the [context
path] only if the server is configured with a context path.

3. Select the IBM TRIRIGA BIRT features.
4. Select the details and select Next.
5. Review and accept the licenses, and select Finish.
6. Restart the BIRT application.
7. In the Workspace field, select the workspace and select OK.
8. In the Eclipse application, select Window > Preferences > IBM TRIRIGA

BIRT Preferences and specify the information to connect to the IBM TRIRIGA
server.

9. Select Test Connection and in the Connected dialog box, select OK.
10. Optional: Configure update notifications.

a. Select Windows > Preferences, expand the Install/Update folder, and
select Automatic Updates.

b. Select Automatically Find New Updates and Notify Me.
c. Select the Update Schedule, Download, and the When Updates are Found

options.
d. Select Apply > Update.

Upgrading the IBM TRIRIGA plug-in
When a new IBM TRIRIGA release is available, you update the IBM TRIRIGA
plug-in in the BIRT Eclipse environment.

Procedure
1. Open the BIRT application, and select Help > About Eclipse.
2. Select Installation Details.
3. In the Installed Software tab, select IBM TRIRIGA BIRT Feature.
4. Select Update.

BIRT report process
Report writers create BIRT reports. BIRT reports are a type of advanced report for
report presentations.

The following steps describe the BIRT report process:
1. Create a starter report in IBM TRIRIGA.
2. Import a starter report to the BIRT Report Designer.
3. Develop a BIRT report.
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4. Preview a BIRT report.
5. Export a BIRT report.
6. Upload a BIRT report to IBM TRIRIGA.
7. Associate the BIRT report with an IBM TRIRIGA access point.

Starter reports in IBM TRIRIGA
Starter report files are downloaded from the IBM TRIRIGA application. You can
create reports from an existing report, a query report, or from a form.

Creating starter reports from query reports
You can create a starter report from a new or existing IBM TRIRIGA query report.
Query reports can contain data from top-level records. They can also contain
multiple levels of detail that are accessible by using associated business objects and
records. Most often, query reports show multi-record reports.

Procedure
1. In the IBM TRIRIGA Report Manager, go to the report or query to use as a

model.
2. Select Advanced and select the BIRT Report link.
3. Select Save.
4. Select the location for the download of the starter file and select Save.

Creating starter reports from forms
You can create a starter report from a new or existing IBM TRIRIGA form. Form
reports typically contain data from a top-level record. They can contain data from
one or more associated records. In the Reports tab of a record, you can select form
reports. You can also run a form report to display the form for multiple top-level
records.

Procedure
1. In the IBM TRIRIGA Form Builder, select Layout and select the BIRT Report

link.
2. Select Save.
3. Select the starter file download location and select Save.

Importing starter reports into BIRT
You import starter reports from IBM TRIRIGA into the BIRT Report Designer.

About this task

If your compressed file extraction tool allows it, you can open the .zip file and in
the BIRT Report Designer Navigator pane, drag the files into a particular report
project.

Procedure
1. In BIRT, select File > New > Project.
2. Select the Business Intelligence folder, select Report Project > Next.
3. Specify the name of the project and select Finish.
4. In the Report Design window, select Navigator, right-click the project, and

select Import.
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5. Select the compressed file that you downloaded when you created a starter
report in IBM TRIRIGA and select Finish.

6. Verify that the starter report shows in the Navigator tab.

Creating BIRT reports
To create a BIRT report, you use the BIRT Report Designer to modify the imported
.rptdesign file. BIRT reports contain information that is IBM TRIRIGA.

Adding data sources
In BIRT reports, all data is accessed through data sources. A starter report includes
a single data source that is named TRIRIGA. TRIRIGA is a scripted data source. All
data sets that obtain their data from an IBM TRIRIGA server must use this data
source.

About this task

If the TRIRIGA data source does not provide all the data that you need, you can
use the data access methods that BIRT supports, including JDBC and XML. You
must add the JDBC data source manually, and it must be named TRIRIGA_DB. At
run time, the report is modified so that it interacts with the IBM TRIRIGA database
that is associated to the server that the report is running on.

Procedure
1. In BIRT, select Data Explorer.
2. Right-Click the Data Sources and select New Data Source.
3. Select JDBC Data Source and in the Data Source Name field specify

TRIRIGA_DB.
4. Select Next.
5. Optional: Select Driver Class and specify the database URL, the user name,

and the password.
6. Specify the database URL, the user name, and the password.
7. In the JNDI URL field, enter jdbc/local/Datasource-TRIRIGA-data, and select

Finish.
8. Right-click Data Sets and select the new data set name.
9. Specify the SQL statement.

10. Optional: Add parameters.
11. Select Finish.

Data sets
A starter report contains at least one data set. The data set models the IBM
TRIRIGA report or the form that was originally created by the BIRT Report.

The name of the data set represents the IBM TRIRIGA report or form. For example,
a data set that models the report triFiscalPeriods_-_Find_-_Years is named
[v2QRY]Classification_triFiscalPeriods_triFiscalPeriods_-_Find_-_Years.

A starter report that is exported from an IBM TRIRIGA query has one data set. The
data set has columns that correspond the columns in the IBM TRIRIGA query. For
example, the IBM TRIRIGA report triFiscalPeriods - Find -Years queries has the
following columns: Name, Start Date, End Date, and Hierarchy Path.

A starter report that is exported from an IBM TRIRIGA form can have multiple
data sets. One data set that has the prefix [v2BO] exists in the starter report. The
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data set represents the top-level data of the form and has columns that correspond
with the business object fields for the form's top-level business object.

Every Smart Section in the business object of a form is represented as a data set
that has the prefix [v2SS]. These Smart Section data sets have columns that
correspond the business object fields in those sections. The
system__parentRecordId input parameter specifies the data to retrieve for this data
set.

Every Query Section in the form is represented as a normal query data set and has
the prefix [v2QRY]. The built-in system__parentRecordId input parameter specifies
the data to retrieve for this data set.

In the starter report, the system__parentRecordId input parameters are not bound
to the top-level business object data set. You must bind the parameters inside the
report layout.

Data types
To preserve data that is from IBM TRIRIGA, the system returns all business object
field data from IBM TRIRIGA in the form of Java Objects. All starter reports have
output columns that are modeled as Java Objects.

Use the following guidelines for Java objects:
v When you use a value in the report, you must know the BIRT Type to map it to.
v If you use values frequently, more scripting is required.
v When you drag an IBM TRIRIGA element directly onto a report, the element

shows in the report.

To use the output column for something other than display, you can access the
SQL value from the output column in any BIRT expression by using the object's
getNativeValue() method.

For example, in the Expression Builder, enter the following value:
row["Classification_triFiscalPeriods_triStartDA"].getNativeValue().

If the Java object has additional methods, you can access them by using any BIRT
expression. When binding one of these expressions results to a report element,
select the appropriate BIRT type to access all the built-in BIRT functions.

When you put the output column on the report, BIRT automatically uses the
toString() method. To access the value, use the following minor
script:row["Classification_triFiscalPeriods_triStartDA"].getNativeValue().

When you export a starter report, all data is mapped to Java Objects inside BIRT.
Every Java Object minimally has the getNativeValue() and toString() methods.

Java objects:

When you export a starter report, all data is mapped to Java Objects inside BIRT.
Every Java Object has the getNativeValue() and the toString() methods.

The following table provides information for additional methods for Java object
and the business object field type.
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Table 1. Java objects

Business object
field type

getNativeValue()
result

Considerations
for toString()

Additional
methods

Suggested
BIRT
binding if
you use
the native
value

Text java.lang.String N/A N/A String

Number

Financial rollup

java.math.Big
Decimal

UOM
metadata and
BO field
masks

getUom().getUom
TypeCode()

getUom.getUom
Value()

Has Uom() returns
false if there is no
UOM.

Decimal

Classification
Rollup

java.math.Big
Decimal

BO field
masks

N/A Decimal

Date java.sql.Date User's
timezone and
preferred
display format

N/A Date

DateTime java.sql.Date User's
timezone and
preferred
display format

N/A Date Time

Time java.sql.Time Is displayed as
hours/
minutes/
seconds with
no timezone
considerations.

N/A Time for
meaningful
results
from this
value, use
a GMT
calendar.

Locator java.lang.String N/A N/A String

Duration java.lang.Long

A single value that
encodes the
Duration
components into a
single value. It is
stored in the IBM
TRIRIGA database
to represent a
particular duration
value. This value
might not represent
the total number of
milliseconds for the
particular duration.

Formats that
use IBM
TRIRIGA-
preferred
format and
considers the
user's
language.

N/A Decimal

Classification java.lang.String
(nontranslated
value)

BO field
option full
hierarchy path
and user's
language

N/A String
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Table 1. Java objects (continued)

Business object
field type

getNativeValue()
result

Considerations
for toString()

Additional
methods

Suggested
BIRT
binding if
you use
the native
value

List java.lang.String
(nontranslated

User's
language

N/A String

Boolean java.lang.Boolean N/A N/A Boolean

Image byte[] Returns path
to image as
stored in IBM
TRIRIGA
database

N/A Image

Binary byte[] String
representation
of the content
ID, the key of
the
DM_CONTENT
table

N/A Blob

UOM java.lang.String

(Non-translated
value)

getUomValue()
translated to
the current
user's
language

getUom().getUom
TypeCode()

getUom.getUom
Value()

getUomValue() is
NULL if there is no
value

String

Password java.lang.String N/A N/A String

SystemField_Bo
RecordId

java.lang.Long N/A N/A Decimal

SystemField_ java.lang.Long N/A N/A Decimal

SystemField_
ModifiedDate Time

java.sql.Date User's
timezone and
preferred
display
format.

N/A Date Time

SystemField_
CreatedDate Time

java.sql.Date User's
timezone and
preferred
display format

N/A Date Time

SystemField_
Modified
DateTimeNumber

java.sql.Date User's
timezone and
preferred
display format

N/A Date Time

SystemField_
ProjectId

java.lang.Long N/A N/A Decimal

SystemField_
BoTypeId

java.lang.Long N/A N/A Decimal

SystemField_Parent java.lang.Long N/A N/A Decimal
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Parameters
In IBM TRIRIGA, queries and reports have parameters that filter the data that is
returned from queries. In the Report Manager, you use the filters to configure
query and report filters.

If a BIRT data set use an IBM TRIRIGA query and that query has user input filters,
each filter is shown in a starter report. The filters are show in the Data Explorer
tab, as a top-level entry in the Report Parameters folder. This report parameter
defines the user prompt that occurs prior to the report execution. The filters also
are shown in the Parameters section, as a parameter of the data set that models the
IBM TRIRIGA query. The entry passes the report parameter value that you specify
to the data set.

When a filter is required, the IBM TRIRIGA query with a user filter appears as a
user prompt and filters the results based on the IBM TRIRIGA query definition.

The default label for a field is the Business Object field's label. You can add a
custom label and help text for these report parameters.

If a report has multiple user filters on the same field, all filters are shown in the
report. BIRT identifies parameters by using a suffix that corresponds to their
positions in the query.

BIRT provides no means to differentiate between a filter to ignore and a NULL
filter value. If you select NULL for a report parameter that maps to an IBM
TRIRIGA query filter, the filter is not used.

For parameter types that are text, you can specify a value of NULL, and the IBM
TRIRIGA query engine uses NULL as the filter value.

The IBM TRIRIGA BIRT integration processes the Time parameter filter correctly
only when you use a String data type for the Time parameter. If you use a Time
data type for the Time parameter filter, the TRIRIGA BIRT viewer does not display
an error, but it does not filter the results properly.

The IBM TRIRIGA BIRT integration processes non-English date and date time
formats on the Date and Date Time filter parameters only if they are set as a String
data type.

Context for data requests
In IBM TRIRIGA, you must add context to data requests. Context is required for
the current user, the record, and the project.

The BIRT preview environment provides the user context from the IBM TRIRIGA
BIRT preferences. The IBM TRIRIGA runtime environment gets data from users
that are signed in.

In both the BIRT preview and IBM TRIRIGA runtime environments, record context
passes through the BIRT report as a report parameter and down to the data sets.

A starter report for a query has a non-required, hidden system__parentRecordId
report parameter. For the query data set, it has a system__parentRecordId input
parameter. When the report runs, if a nonzero value is passed through the
parameter to IBM TRIRIGA, it becomes the $$RECORDID$$ value when the IBM
TRIRIGA query runs.
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In a starter report for a form, the system__recordIds parameter is a required report
parameter. The system__recordIds parameter is a comma-delimited list of record
IDs that the form report renders. You can use multiple IDs for the bulk-reporting
requirements.

In a BIRT preview environment, a prompt is used to collect for the
system__recordIds value to preview the form report. The following
system__recordIds is an example: system_recordIds 1590609, 1345105, 1295530.

In a report definition, even though the report has a parameter that is configured as
not-hidden, the prompt is not shown inside an IBM TRIRIGA runtime
environment, because the runtime environment provides the value.

In the BIRT preview environment, you can specify a project context in the IBM
TRIRIGA BIRT Preferences section by using the project ID input. The BIRT preview
environment uses the project ID input to provide project context for any IBM
TRIRIGA requests.

System fields
Some fields that are built in to a BIRT report are not built into IBM TRIRIGA
Business Object fields.

The following table contains system fields with special names that have special
meaning to the IBM TRIRIGA-BIRT integration.

Table 2. System fields

System field Usage Description

system__recordIds Data set input parameter for
business object data sets.

Report Input Parameter for
Form Reports.

Comma-delimited list of
record IDs that control the
records that are returned
from Form reports. Required
if you do not use the
system_recordId input
parameter.

system__recordId Data set Input Parameter for
Business Object data sets.

Numeric value that
represents a single record to
return from a Business
Object data set. For a query
report, this field is required.
For a form report, this field
is required if you do not use
the system_recordIds input
parameter.

system_parentRecordId Data set Input Parameter for
query data sets.

Data set Input Parameter for
smart section data sets.

Report Input Parameter for
Query Report.

Provides record context to
reports and data sets.

For smart sections,
system_parentRecordId is a
required value that controls
which record's section data
to return.

For Query data sets, the
$$RECORDID$$ and
$$PARENT variables are used
in an IBM TRIRIGA Query
definition.
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Table 2. System fields (continued)

System field Usage Description

system__recordId Output Column for all types
of IBM TRIRIGA data sets.

Every IBM TRIRIGA data set
has an output column named
system_recordId. The
column contains the record
ID of the returned record.
The only case where this
column is returned with a
NULL value is for a
reference that will not pass
through with smart section
that is modified. In that case,
there is no built in IBM
TRIRIGA record.

system__sourceRecordId Data set Output Column for
smart section data sets.

Every smart section data set
has an output column that is
named
system_sourceRecordId. The
value holds the data that a
smart section record was
initialized from, which is
called the source record. The
system_sourceRecordId helps
to differentiate the section
record from the source
record.

Globalization
Starter reports and the IBM TRIRIGA-BIRT integration have features to assist with
the globalization of reports. Before you export labels for BIRT reports, make sure
that these reports are set up in IBM TRIRIGA.

The IBM TRIRIGA-BIRT integration to localize dates. The display string for any
IBM TRIRIGA Date or DateTime field is formatted in the user's preferred date
format. In addition, the formatDate() custom function and the formatDateTime()
custom present a BIRT Date or DateTime in the IBM TRIRIGA user's preferred date
format.

IBM TRIRIGA translates all labels in the BIRT report. The starter report includes all
the labels that are needed to translate the business object field labels in a report.

A starter report is associated to a resource properties file with an
tririgalabels.properties extension. You can view this association in the
Resources section in the Property Editor – Report tab. This report resource points
to a properties file that contains label keys for every business object field that was
built into the report.

In the starter report, each key is already associated to its corresponding data set
output column in BIRT. If you use the Data Explorer as a canvas, you can drag
elements onto the canvas without having to reassociate the display keys for those
elements. If you do not drag elements onto the canvas, you can use all the labels in
the properties file on any report element. You use the labels in the properties file
when you select a report element in the layout and navigate to the Localization
Properties section in the Properties tab of the Property Editor – Label tab. At run
time, text that uses these keys is translated based on the current user's language.
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If you need a label in your report that is not available from the starter report
properties file, you can add keys and labels to the file. Key name is that it cannot
begin with the [FIELD] special prefix. IBM TRIRIGA can translate any label that
you create.

A BIRT report library can house reusable report elements, including labels. You
create a properties file with the tririgalabels.properties extension and refer to
that properties file as a library resource. To view an properties file for a BIRT
report library, select the library in the BIRT navigator, and view the properties in
the Property Editor – Library tab. To read the library, each BIRT report must
reference the library before you export and upload the report to IBM TRIRIGA.

Subreports
You can build subreports into the top level of a report or put them in separate
.rptdesign files.

For example, a report might show purchase order headers. For each header, a
report can show line items for that particular purchase order. In this case, the
purchase order line items are shown as a subreport of the purchase order header
data.

You can build subreports into the .rptdesign file as the main report. A single
report might show fiscal years and fiscal quarters, where fiscal years are the parent
records and the report displays the fiscal quarters for each fiscal year.

Use the following guidelines for single reports:
v A record ID is returned for each result of a parent data set.
v The child IBM TRIRIGA query filters results based on the parent record.
v The child data set takes a parent ID as a parameter. If BIRT sends a

system_parentRecordId with a default value of 0, the IBM TRIRIGA system
ignores it.

v In the report layout's child table, the data set Parameter Binding binds the
parent record's ID to the child data set's input parameter.

You can build subreports into different .rptdesign files. For example, you can
show all fiscal years in a single list that uses a hyperlink to take the user to the
quarters for the selected year. In this case, the fiscal quarters is a separate
.rptdesign file.

Use the following guidelines for separate report files:
v At the top level of any compressed file that you import into IBM TRIRIGA, there

must be at least one .rptdesign file. Any subreports in other .rptdesign files
must be in a child directory.

v When you configure a hyperlink, the system__recordId from the top-level report
must be bound to the system__parentRecordId report parameter of the
subreport. An example of this includes fiscal years and fiscal quarters.

Custom functions
Custom functions assist you with particular use cases. The custom functions are in
the TRIRIGA category of the BIRT Expression Builder.

The following table describes the custom functions:
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Table 3. Custom functions. Custom functions

Name Description Inputs Return

formatNumber Uses IBM TRIRIGA
to format a number.

number - BigDecimal:
Number value to
format

unitOfMeasure -
TriResultUom: Unit
of Measure that is
used for formatting
the number. Can use
a NULL value if no
UOM is available,
but must use the
encodedBoFieldName
input.

encodedBoFieldName
- String [optional]:
BO field from which
this number came.
Use where
applicable, because a
field metadata can
affect number
formatting.

String: the formatted
number.

formatDate Uses IBM TRIRIGA
to format a date.
Uses your preferred
format that is
specified in the user
profile record.

date - java.util.Date:
Date to format

String: the formatted
date.

formatDateTime Uses IBM TRIRIGA
to format a datetime.
Uses your preferred
format that is
specified in the user
profile record.

dateTime -
java.util.Date:
DateTime to format

String: the formatted
DateTime.

getProjectIdFor-
Record

Returns the record ID
of the project that the
record is in. Returns
NULL if the record is
not in a project.

ID of the record.
Typically the
system__recordId
value of an IBM
TRIRIGA result
record.

Decimal: the ID of
the project that the
record is in.

getRootOrganiza-
tionId

Returns the record ID
of the root
organization.

N/A Decimal: the ID of
IBM TRIRIGA's root
organization record.

getCompany-LogoId Returns the ID of the
company logo
document.

N/A Decimal: the ID of
the company logo
document.

getProjectLogoId Returns the ID of the
current project's logo
document.

N/A Decimal: the ID of
current project's logo
document.

getUserId Returns the ID of the
currently signed-in
user.

N/A Decimal: the ID of
the current user.
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Table 3. Custom functions (continued). Custom functions

Name Description Inputs Return

getProjectId Returns the ID of the
current project.
Returns NULL if the
user is not currently
in a project.

N/A Decimal: the ID of
current project.

Preview BIRT reports
You preview reports by using the Preview tab in the BIRT Report Designer. In the
BIRT application, you set values in the IBM TRIRIGA BIRT Preferences section to
pass context from IBM TRIRIGA to a BIRT report during preview execution. You
set the preference values when you specify the connection information to the IBM
TRIRIGA server.

You can pass the following types of context:

Current user
Set when you specify the IBM TRIRIGA app server, user name, and
password field values.

Active project
Set when you specify the record ID of a particular project. The active
project causes the preview to simulate execution within the context of the
specified Capital project.

Input parameters
Prompted by the BIRT application. When you preview the report, the BIRT
application prompts you for any input parameters that are defined on the
report. Those values also serve as context to the report execution.

Exporting BIRT reports
You export BIRT reports back to IBM TRIRIGA so that the IBM TRIRIGA
environment can use the reports.

Packaging BIRT reports
Before you export the BIRT report back to IBM TRIRIGA, you package the report
as a .zip file.

Procedure
1. In BIRT, right-click the report project and select Export.
2. Expand the general folder, select Archive File, and select Next.
3. Select Report Building.
4. Select the .rptdesign and tririgalabels.properties files.
5. In the To Archive File field, name the new .zip file and select the upload

location.
6. Select the options that you want to use.
7. Select Finish.

Uploading reports to IBM TRIRIGA
You use the Document Manager to upload the packaged .zip file to IBM TRIRIGA.
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Procedure
1. In IBM TRIRIGA, open the Document Manager.
2. Expand the IBM TRIRIGA folder.
3. Select or create the upload folder. You can use a folder name that corresponds

to the module of the starter report and IBM TRIRIGA query.
4. Select New Document, select Browse, and select the BIRT report file.
5. Specify a document name.
6. Optional: Specify field values.
7. Select Upload and select OK.

Report libraries
A report library is a BIRT construct that holds reusable components that you share
across multiple reports.

You upload a report library in the same way you upload a report.

You upload the report libraries to the IBM TRIRIGA Document Management
system and to the \ROOT\TRIRIGA\BIRT Libraries folder. If this folder structure
does not exist in your system, create the folder.

The report library can be uploaded either as a single .rptlibrary file or as a .zip
file.

The name of the IBM TRIRIGA document must be the same as the name of the
.rtplibrary file.

If the report library contains labels, the .rptlibrary file can reference a
tririgalabels.properties file that can have translatable labels.

Associating documents to IBM TRIRIGA
To make a BIRT report usable, you associate the IBM TRIRIGA document to an
IBM TRIRIGA access point. Access points are either a query report or form report.

Associating documents to query reports
You create an IBM TRIRIGA query as an external query. The query acts as a link to
the BIRT .rpt file that you uploaded to the Document Manager. In the Document
Manager, you select the BIRT report. You can use the report in many places
throughout IBM TRIRIGA, such as form sections and portal sections.

Procedure
1. In IBM TRIRIGA, open the Report Manager.
2. Select System Reports > New.
3. Specify the information.
4. Select Save and Close.

Associating documents to forms
You can use reports in many places in IBM TRIRIGA, such as form sections, portal
sections, and the Reports tab.

About this task

To use a BIRT report in a form section, add the report to the Layout tab and the
Includes/Forms tab of a form. In the Includes/Forms tab, associate the BIRT report

18 © Copyright IBM Corp. 2011, 2015



to the IBM TRIRIGA form. As a result, all the labels on the BIRT report can be
exported for translation from the globalization manager.

Procedure
1. In IBM TRIRIGA, go to the Form Builder and select General.
2. Open the form for which you developed the form report.
3. Optional: Revise the form.
4. Select Layout and select Show Reports to ensure that the report appears in the

Reports tab of a form.
5. Select the Includes/Forms and select Add.
6. Select the report file that you uploaded into the Document Manager and select

OK.
7. In the forms section, select the report file.
8. Select Layout and select Publish.

Configuring bulk print actions after object migration
In the IBM TRIRIGA application, bulk print report actions use URLs that have
hardcoded numerical document IDs. After you apply an object migration package,
the document ID of a document can change, and the bulk print action no longer
works. You can manually update each document ID and associate each document
with the related form.

Configuring bulk print actions in maintenance forms
You can configure actions in maintenance forms for a bulk print.

Procedure
1. Sign in to IBM TRIRIGA as an administrator.
2. In the Document Manager, select TRIRIGA > Task.
3. Right-click one of the documents in the following table and select Properties

to get the document ID. Repeat this step for each document in the following
table:

Document Name Bulk Print Action

Condition Assessment Work Task Record
(BIRT)

Print Condition Assessment Work Task

Contract Review Record (BIRT) Print Contract Review

Inspection Task Record (BIRT) Print Inspection Task

Inventory Count Work Task Record (BIRT) Print Inventory Count Work Task

Inventory Pick Work Task Record (BIRT) Print Inventory Pick Work Task

Key Work Task Record (BIRT) Print Key Work Task

Material Order Task Record (BIRT) Print Material Order Task

Punchlist Task Record (BIRT) Print Punchlist Task

Reserve Work Task Record (BIRT) Print Reserve Work Task

Schedule Task Record (BIRT) Print Schedule Task

Submittal Task Record (BIRT) Print Submittal Task

Work Task Record (BIRT) Print Work Task

4. From the Tools menu, select Builder Tools > Form Builder.
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5. Select the triMaintenance module, select the triMaintenanceManager form,
and revise the form.

6. In the form navigation, select triSchedule > Work > My Tasks.
7. Select the bulk print action. In the action properties, replace the old document

ID with the new document ID. Repeat this step for each action in the previous
table.

8. After you update all of the document ID values, publish the form.
9. From the Tools menu, and select Builder Tools > Form Builder.

10. Select the triTask module. Open a task form from the following table and
revise the form.

11. Select Includes/Forms and in the forms section, select Add. Locate the
document and publish the form. Repeat this step for each form in the
following table.

Task Form Document Name

triConditionAssessmentWorkTask Condition Assessment Work Task Record
(BIRT)

triContractReviewTask Contract Review Record (BIRT)

triInventoryCountWorkTask Inventory Count Work Task Record (BIRT)

triInventoryPickWorkTask Inventory Pick Work Task Record (BIRT)

triKeyWorkTask Key Work Task Record (BIRT)

triMaterialOrderTask Material Order Task Record (BIRT)

triPunchlistTask Punchlist Task Record (BIRT)

triReserveWorkTask Reserve Work Task Record (BIRT)

triScheduleTask Schedule Task Record (BIRT)

triSubmittalTask Submittal Task Record (BIRT)

triWorkTask Work Task Record (BIRT)

Configuring bulk print actions in invoice forms
You can manually configure bulk print actions in invoice forms.

Procedure
1. Sign in to the IBM TRIRIGA application as an administrator.
2. In the Document Manager, navigate to TRIRIGA > Contract.
3. Right-click a document from the following table, and select Properties to get

the document ID. Repeat this step for each document in the following table:

Document Name Bulk Print Action

Asset Invoice Summary Bulk Print (BIRT) Bulk Print Asset Invoices

RE Invoice Summary Bulk Print (BIRT) Bulk Print RE Invoices

4. From the Tools menu, select Builder Tools > Form Builder.
5. Go to the triPayment module, select the triProcessInvoices, and revise the

form.
6. In the form navigation, select triGeneral > AR Invoices.
7. In the AR invoices properties, select one of the bulk print actions. In the action

properties, replace the old document ID with the new document ID. Repeat
this step for each action in the previous table.
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8. After you update all of the document ID values, publish the form.
9. Go to the Tools menu and select Builder Tools > Form Builder.

10. Select the triPayment module. Open an invoice form from the following table
and revise the form.

11. Select Includes/Forms and in the forms section, select Add. Locate the
document and publish the form. Repeat this step for each form in the
following table:

Invoice Form Document Name

triAssetInvoice Asset Invoice Summary Bulk Print (BIRT)

triREInvoice RE Invoice Summary Bulk Print (BIRT)

Report maintenance
You can change existing reports that do not involve data sets and you can change
existing reports that do involve data sets.

Modifying reports without data set changes
To modify a BIRT report that does not involve data set changes, you use the
Document Manager to retrieve the report file, change the file, and reimport the
report file.

Procedure
1. In the Document Manager, select the file, specify a comment, and select Check

Out.
2. Create a starter report in IBM TRIRIGA and import the starter report into BIRT.
3. Make any needed changes to the report and save the file. If you change a

standard BIRT report, rename the report before you load it into the Document
Manager to protect your customized version in the case of an IBM TRIRIGA
upgrade.

4. Upload the file back into the Document Manager.

Modifying reports with data set changes
Use the Document Manager to retrieve the report file, change the report file, and
reimport the report file.

Procedure
1. Generate a starter report that is based on the same model that you used for the

existing BIRT report.
2. Do one of the following options:

Options Modifying reports with data set changes

Select updates from script-data-set
elements

Select the updates to include from the
script-data-set elements in the current BIRT
report and in the new .rtpdesign file.

Replace the script-data-set elements Replace the script-data-set elements of the
current .rptdesign file with the new
script-data-set elements that are generated in
the new .rptdesign file. Import the starter
report into a project, copy the data set from
the new starter report, and paste it in the
data sets of the existing .rptdesign file.
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What to do next

If you add fields or user filters to the IBM TRIRIGA query, you must also change
the report. After you update the data set, if that data set is used to join inside
BIRT, you must rejoin the data set, and rebind the elements in the BIRT report.

Filter operators
The values for filter operators depend on the field type of the selected field.

The following table lists and describes the values that you can use:

Table 4. Filter operators. Field operators

Operator Description

After Available for date, date and time, and time fields. If the value
of the specified field is after the specified value, it is true

Before Available for date, date and time, and time fields. If the value
of the specified field is before the specified value, it is true,

Contains Available for Text, UOM, and Boolean fields. If the value of
the specified field contains the specified value, it is true.

Contains – Case Sensitive Available for Text, UOM, and Boolean fields. If the value of
the specified field contains the specified value, case-sensitivity
included, it is true.

Does Not Contain Available for Text, UOM, and Boolean fields. If the value of
the specified field does not contain the specified value, it is
true.

Does Not Contain – Case
Sensitive

Available for Text, UOM, and Boolean fields. If the value of
the specified field does not contain the specified value,
case-sensitivity included, it is true

End With Available for Text, UOM, and Boolean fields. If the value of
the specified field ends with the specified value, it is true.

End With - Case Sensitive Available for Text, UOM, and Boolean fields. If the value of
the specified field ends with the specified value and it is
case-sensitive, it is true.

Equals If the value of the specified field is equal to the specified
value, it is true.

In If the value of the specified field is one of the specified values,
it is true. For string and numeric values, the specified values
should be comma-separated literal values that are wrapped in
single quotation marks, for example: 'Tom','Jerry','Paul','1','2','3'.

Less Than Available for number fields. If the value of the specified field
is less than the specified value, it is true.

Less Than or Equals Available for number, date, date and time, and time fields. If
the value of the specified field is less than or equal to the
specified value, it is true.

More Than Available for number fields. If the value of the specified field
is greater than the specified value, it is true.

More Than or Equals Available for number, date, date and time, and time fields. If
the value of the specified field is greater than or equal to the
specified value, it is true.

Not Equals If the value of the specified field is not equal to the specified
value, it is true.
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Table 4. Filter operators (continued). Field operators

Operator Description

Not In If the value of the specified field is not one of the specified
values, it is true. For string and numeric values, the specified
values should be comma-separated literal values that are
wrapped in single quotation marks. For example:
'Tom','Jerry','Paul','1','2','3'.

Start With Available for Text, UOM, and Boolean fields. If the value of
the specified field begins with the specified value, it is true.

Start With - Case Sensitive Available for Text, UOM, and Boolean fields. If the value of
the specified field begins with the specified value and it is
case-sensitive, it is true.

If you have query that is used in a locator field or a smart
section and you notice that autocomplete takes a long time to
run, consider changing the filter Operator from contains to
starts with.

Special values
In addition to using numbers and text in the Value field, you can use special
values.

The preceding special values can be followed by a + or - and a whole number. For
example, $$TODAY$$+1 is tomorrow, $$THISWEEK$$-1 is last week, and
$$THISYEAR$$+5 is five years after the current year. The following table lists and
describes the special values:

Table 5. Special values that can be followed by a + or a -.. Special values

Value Description

$$TODAY$$ Used to compare a date to the current date.
For example, if you do not want to show
training courses that were in the past,
specify: General::Start Date After
$$TODAY$$

$$THISWEEK$$ Used to compare a date to the current week.
For example, to see training courses that
start in the current week, specify:

General::Start Date Equals $$THISWEEK$$

$$THISMONTH$$ Used to compare a date to the current
month.

$$THISYEAR$$ Used to compare a date to the current year.

The following table lists and describes more the special values:
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Table 6. Special Values. Special values

Value Description

$$RUNTIME$$ The $$RUNTIME$$ special value allows the
user to specify a value for the filter when
the report is run. If the user does not specify
a value, the filter is ignored.

The $$RUNTIME$$ special value works well
with most data types and comparison
operators. However, for text data, the
$$RUNTIME$$ special value works with the
Contains operator.

Instead of using the $$RUNTIME$$ special
value, you can identify fields for user input
by selecting the User check box in the
Filters tab.

$$USERID$$ The $$USERID$$ special value is a valid field
filter in queries.

$$USERID::SectionName::FieldName$$ The $$USERID::SectionName::FieldName$$
special value is a valid filter in queries.
Setting the value field to the
$$USERID::SectionName::FieldName$$ special
value indicates that a value is compared
with the field name FieldName in the
SectionName section of the record.

$$PERSONID$$ The $$PERSONID$$ special value is a valid
field filter in queries. When the
$$PERSONID$$ special value is used, it
resolves to the smart object ID of the person
that is associated to the current user. If the
current user is not associated to a person, an
error is displayed.

Similar to the $$USERID$$ special value, it
supports section and field access. The
following example is a valid notation to
resolve the first name of the current person:
$$PERSONID::Detail::triFirstNameTX$$.

$$PARENT::SectionName$$ The $$PARENT::SectionName$$ special value
is a valid field filter in queries. Setting the
Value field to the $$PARENT::SectionName$$
special value indicates that a value is
compared with the SectionName section of
the record that contains the query section or
smart section.
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Table 6. Special Values (continued). Special values

Value Description

$$PARENT::SectionName ::FieldName$$ You can indicate a filter that compares a
value in the record that is filtered with a
value in the record that contains the smart
section.

To indicate that a value is compared with
the FieldName field in the SectionName
section of the record that contains the query
section or smart section, use the following
value field:
$$PARENT::SectionName::FieldName$$.

If the value of the $$PARENT special value is
empty, it resolves to an IS NULL criteria.

Special names in the record field
In the record field, you can use special names to filter for an association with
special records.

The value of a record or query field must be the same as the name of the other
query. If the value of the filter type field is query, set the appropriate record or
query.

If the value of the filter type field is record, the value of the record or query field
determines whether the association that the filter requires is directly with the
context record, with another record that is associated with the context record, or an
unassociated record.

The following table contains special names for the record field:

Table 7. Special names in the record field

Value Description

$$USERID$$ When the query is run, the $$USERID$$ value
resolves to the record ID of the user that
started the query.

$$PERSONID$$ When the query is run, the $$PERSONID$$
value resolves to the record ID of the People
record that is associated with the user who
started the query.

$$RECORDID$$ Useful for queries that are used in the query
sections and for the find action queries for
data sections. Queries that are used in query
sections and find queries are often required
to return only records that are associated
with the record that contains the section.

When you set the record field to the
$$RECORDID$$ value, if the top-level records
are associated directly with the context
record, then the top-level records pass this
filter.

Chapter 2. Advanced reporting in IBM TRIRIGA 25



Table 7. Special names in the record field (continued)

Value Description

$$GROUPID$$ If you set the record field to the $$GROUPID$$
value, if the top-level records are associated
with a record that represents a group that
the user is a member of, then the top-level
records pass the filter.

If the record field is set to the $$GROUPID$$
value, the Module field is set to Group and
the Business Object field is set to All.

$$PROJECTID$$ When you set the record field to the
$$PROJECTID$$ value and if the top-level
records are associated with a record that
represents the active project, then the
top-level records pass the filter.

If the record field is set to $$PROJECTID$$,
the Module field is set to triProject and
the Business Object field is set to All.

Projects in IBM TRIRIGA provide a way to
classify data for relevance to the tasks on
which people work.

$$PARENT$$ Use $$PARENT$$ to specify that top-level
records pass this filter if they are associated
with a record that has a direct or indirect
association with the context record. It works
by specifying a path from the context record
to another record through record sections or
locator fields.

For example, if a context record is an
employee record, the report should include
employee records for employees who have
the same supervisor as the context record.

To specify a filter, use the employee records
that have a locator field that is named
triReportsToTX that references the record
that corresponds to an employee’s
supervisor. If triReportsToTX is in the
general section, the value of the record field
is $$PARENT::General::triReportsToTX$$.

If the reference was a smart section, the
value of the record field would be
$$PARENT::triReportsTo$$.

If the value of $$PARENT$$ is empty, it
resolves to an IS NULL criteria.

$$PARENT::SECTIONNAME$$ Use to filter a find section based on values
in another section. PARENT is always the
word PARENT. SECTIONNAME is the name of
the section that contains the values that you
want to filter. Make sure that you use the
name and not the label of the section.
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Table 7. Special names in the record field (continued)

Value Description

$$PARENT::SECTIONNAME::FIELDNAME$$ Used to filter a find section based on the
value of a field in another section. PARENT is
always the word PARENT. SECTIONNAME is
the name of the section that contains the
field that you want to filter. FIELDNAME is the
name of the field by which you want to
filter. Make sure that you use the name and
not the label of the section and field.

$$ORGANIZATIONID$$ Used to filter a portal query section based
on the organizations of the user who is
logged in.

$$ORGANIZATIONIDWITHCHILDREN$$ Used to filter a portal query section based
on the organizations, including all
dependent child organizations, of the user
who is logged in.

$$GEOGRAPHYID$$ Used to filter a portal query section based
on the geography of the user who is logged
in.

$$GEOGRAPHYIDWITHCHILDREN$$ Used to filter a portal query section based
on the geography and all child geographies
of the user who is logged in.
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Notices

This information was developed for products and services offered in the US. This
material might be available from IBM in other languages. However, you may be
required to own a copy of the product or product version in that language in order
to access it.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive, MD-NC119
Armonk, NY 10504-1785
US

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of
express or implied warranties in certain transactions, therefore, this statement may
not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM websites are provided for
convenience only and do not in any manner serve as an endorsement of those
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websites. The materials at those websites are not part of the materials for this IBM
product and use of those websites is at your own risk.

IBM may use or distribute any of the information you provide in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Director of Licensing
IBM Corporation
North Castle Drive, MD-NC119
Armonk, NY 10504-1785
US

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

The performance data and client examples cited are presented for illustrative
purposes only. Actual performance results may vary depending on specific
configurations and operating conditions.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

Statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to actual people or business enterprises is entirely
coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
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programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work must include a copyright notice as follows:
© (your company name) (year).
Portions of this code are derived from IBM Corp. Sample Programs.
© Copyright IBM Corp. _enter the year or years_.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the web at "Copyright and
trademark information" at www.ibm.com/legal/copytrade.shtml.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Linux is a trademark of Linus Torvalds in the United States, other countries, or
both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Other product and service names might be trademarks of IBM or other companies.

Terms and conditions for product documentation
Permissions for the use of these publications are granted subject to the following
terms and conditions.

Applicability

These terms and conditions are in addition to any terms of use for the IBM
website.

Personal use

You may reproduce these publications for your personal, noncommercial use
provided that all proprietary notices are preserved. You may not distribute, display
or make derivative work of these publications, or any portion thereof, without the
express consent of IBM.

Commercial use

You may reproduce, distribute and display these publications solely within your
enterprise provided that all proprietary notices are preserved. You may not make
derivative works of these publications, or reproduce, distribute or display these
publications or any portion thereof outside your enterprise, without the express
consent of IBM.
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Rights

Except as expressly granted in this permission, no other permissions, licenses or
rights are granted, either express or implied, to the publications or any
information, data, software or other intellectual property contained therein.

IBM reserves the right to withdraw the permissions granted herein whenever, in its
discretion, the use of the publications is detrimental to its interest or, as
determined by IBM, the above instructions are not being properly followed.

You may not download, export or re-export this information except in full
compliance with all applicable laws and regulations, including all United States
export laws and regulations.

IBM MAKES NO GUARANTEE ABOUT THE CONTENT OF THESE
PUBLICATIONS. THE PUBLICATIONS ARE PROVIDED "AS-IS" AND WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING
BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY,
NON-INFRINGEMENT, AND FITNESS FOR A PARTICULAR PURPOSE.

IBM Online Privacy Statement
IBM Software products, including software as a service solutions, (“Software
Offerings”) may use cookies or other technologies to collect product usage
information, to help improve the end user experience, to tailor interactions with
the end user, or for other purposes. In many cases no personally identifiable
information is collected by the Software Offerings. Some of our Software Offerings
can help enable you to collect personally identifiable information. If this Software
Offering uses cookies to collect personally identifiable information, specific
information about this offering’s use of cookies is set forth below.

This Software Offering does not use cookies or other technologies to collect
personally identifiable information.

If the configurations deployed for this Software Offering provide you as customer
the ability to collect personally identifiable information from end users via cookies
and other technologies, you should seek your own legal advice about any laws
applicable to such data collection, including any requirements for notice and
consent.

For more information about the use of various technologies, including cookies, for
these purposes, see IBM’s Privacy Policy at http://www.ibm.com/privacy and
IBM's Online Privacy Statement at http://www.ibm.com/privacy/details in the
section entitled “Cookies, Web Beacons and Other Technologies,” and the "IBM
Software Products and Software-as-a-Service Privacy Statement" at
http://www.ibm.com/software/info/product-privacy/.
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